My FF on the road again

Discussion in '1st & 2nd Generation 1983-1989' started by Ascalon, Aug 14, 2018.

  1. Ascalon

    Ascalon New Member

    Country:
    Ireland
    Joined:
    Aug 28, 2006
    Messages:
    11
    Likes Received:
    3
    Trophy Points:
    3
    Greetings all,
    its been a while since I posted.
    Just wanted to share a couple of pics of the beast - my 85 FF, heavily customised.
    It's now in daily use, but has had quite a rest recently. :)
    [​IMG]

    She's on first overbore, with an oiling kit.
    Wilbers suspension, CBR wheel conversion, and a few other bits and bobs you'll no doubt spot.

    [​IMG]

    Plus, the decal kit is from an 84 white/red bike, but I just like them :)

    Toodle pip,

    A
     
    Last edited: Aug 14, 2018
    duccmann, Samuel and sixdog like this.
  2. sixdog

    sixdog Member

    Country:
    United States
    Joined:
    Sep 5, 2010
    Messages:
    403
    Likes Received:
    101
    Trophy Points:
    58
    Location:
    CA
    Map
    Outstanding!!!!
     
    Ascalon likes this.
  3. OOTV

    OOTV Member

    Joined:
    Aug 20, 2011
    Messages:
    6,467
    Likes Received:
    943
    Trophy Points:
    143
    Location:
    Anaheim, Ca.
    Nice to see an early model still running and looking so clean.
     
  4. Captain 80s

    Captain 80s Member

    Country:
    United States
    Joined:
    Apr 25, 2009
    Messages:
    3,152
    Likes Received:
    766
    Trophy Points:
    158
    Location:
    Edmonds, WA
    Me likey! Always loved that seat you did. Front fender for an 18" wheel, right?
     
  5. straycat

    straycat Member

    Country:
    Canada
    Joined:
    Jun 27, 2017
    Messages:
    953
    Likes Received:
    310
    Trophy Points:
    63
    great looking Bike !
     
  6. Ascalon

    Ascalon New Member

    Country:
    Ireland
    Joined:
    Aug 28, 2006
    Messages:
    11
    Likes Received:
    3
    Trophy Points:
    3
    Aye, it is surely.
    Can't take any credit for the seat, the previous owner had that custom made in Germania. :)

    And yes, I didn't bother changing the front mudguard when I went from the 18" to the 17" front, as I was after that motox look! ;)

    She runs and rides very well now, the only thing I'm looking to do is improve the front brake feel. It has Brembo discs and braided lines, but I might see if there's a better compound pad that might give me more initial bite.

    Also, the neutral light is rather eratic, and I need to see if it is buggered or just looking for attention.

    Does anyone have any experience running a LiPo battery on one of these?

    I recently changed the stator for a Chinese copy and got a modern reg/rec for it, which seems to be OK. It is currently running a Unibat AGM battery, which seems good, but I have lithium one soon to be spare that is like a feather in comparison.
     
  7. jeremyr62

    jeremyr62 New Member

    Country:
    Ireland
    Joined:
    May 14, 2011
    Messages:
    598
    Likes Received:
    38
    Trophy Points:
    28
    Location:
    Limerick, Ireland
    Map
    Not in a thou but I have a LiPo in a VF500. Works fine. Hard to believe it can spin the engine, it is so light.
     
    Ascalon likes this.
  8. PawnBoy

    PawnBoy New Member

    Country:
    Canada
    Joined:
    Jun 23, 2013
    Messages:
    283
    Likes Received:
    24
    Trophy Points:
    18
    Location:
    Waterloo, ON
    Map
    That looks very nice.
     
    Ascalon likes this.
  9. duccmann

    duccmann Member

    Country:
    United States
    Joined:
    Oct 6, 2010
    Messages:
    9,207
    Likes Received:
    907
    Trophy Points:
    143
    Location:
    SoCal
    Map
    Man, that is one beautiful machine


    Sent from my iPhone using Tapatalk
     
    Ascalon likes this.
  10. Ascalon

    Ascalon New Member

    Country:
    Ireland
    Joined:
    Aug 28, 2006
    Messages:
    11
    Likes Received:
    3
    Trophy Points:
    3
    Have been running the bike for about a week now with the X-Racer Lithium 6 battery and it seems to be fine.
    I've been keeping an eye on the voltage and it seems pretty stable at 13.5v or so after usage. No issues at all starting either.

    Looks good.
     
Related Topics

Share This Page